Videos from this blog

Loading...

Monday, 29 March 2010

INSTALLING PLAYER-STAGE : WHAT WORKED FOR ME


PLAYER/STAGE INSTALLATION GUIDE ON UBUNTU 9.04, 10.04 LTS AND 12.04 LTS







Player-Stage or as it is now know, Player Project is a very versatile software for robot simulation and hardware control interface. It primarily uses FLTK and OpenGL.

After trying various means and hopelessly failing, I successfully installed Player-Stage in Ubuntu 9.04 (and much later also on Ubuntu 10.04 - scroll down for that).

The following is a succinct of my efforts. 

INSTALLING PLAYER/STAGE IN UBUNTU 9.04 AND UBUNTU 10.04 LTS

The post primarily deals with installation in Ubuntu 9.04, for installation in Ubuntu 10.04 LTS and 12.04 LTS scroll down, close to the end of this post.  

THE INSTALLATION : IN 8 SIMPLE STEPS

#1.Update Ubuntu

A fresh installation of the OS (Ubuntu 9.04 ) is preferred.

Update Ubuntu 9.04 completely using sudo apt-get update and sudo apt-get upgrade. (Do not do a distribution update to Ubuntu 9.10 or higher)

#2.Install the dependencies

Dependencies for installation in Ubuntu 9.04;

sudo apt-get install autotools-dev build-essential cmake cpp libboost-signals1.35.0 libboost-signals1.35-dev libboost-thread1.35.0 libboost-thread1.35-dev libcv1 libcv-dev libgdk-pixbuf2 libgdk-pixbuf-dev libgnomecanvas2-0 libgnomecanvas2-dev libgsl0-dev libgtk2.0-dev libjpeg62-dev libtool libxmu-dev swig
freeglut3 freeglut3-dev libfltk1.1 libfltk1.1-dev libltdl7 libltdl7-dev libpng12-0-dev libpng12-0

Make sure all these packages (or any alternative packages (hardly one or two) offered by Ubuntu 9.04 repositories, i.e. in case If libpng12-dev or any such package is not installed by apt-get, then install it manually) are installed. Run the above commands 2 to 3 times to confirm that these packages are indeed installed.

#3.Download the sources

Download Player-3.0.0 and Stage-3.2.0-Source and extract the files. Restart the computer for dependencies to come to effect.

#4.Configure and install player and stage in the $usr/local directory

Do not try to install Stage before installing Player. Stage installation script 'looks for' player installation

Installing Player

execute each of these commands (5 in total) one at a time in the same order as shown

cd player-3.0.0

mkdir build

cd build

cmake ../

make
sudo make install

Installing Stage

An Error in Stage files : Before installation, there is an error in Stage files that should be corrected,
in the source code in the file Stage-3.2.0-Source/libstageplugin/p_driver.cc closer to the end of the file, Change the line : "world->Update();" to "Fl::wait();" . This error has been rectified in later versions of Stage (i.e. Stage-3.2.2 etc).

Now install, much like Player,
execute each of these commands (4 in total) one at a time in the same order as shown.

cd Stage-3.2.0-Source

mkdir build
cd build

cmake ../

make
sudo make install

#5.Confirming the installation

#6.Setting the 'PATH'

In the 'home' folder enable 'show hidden files' and locate the .bashrc file.

At the end of the .bashrc file append the following.
PATH=$PATH:/usr/local/bin
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
export PATH
export LD_LIBRARY_PATH
export PKG_CONFIG_PATH

Then run the command source ~/.bashrc from the terminal, restart the computer

#7. Check !  

In the Stage installation files

cd Stage-3.2.0-Source/worlds

Start the simulation with,  player simple.cfg

If the following screen with a little red robot, pops up then everything is set up nicely !

#8. Check for compilation

In Player installation files, cd player-3.0.0/examples/libplayerc++ 

compilation command for sonarobstacleavoid.cc

g++ -o laserobstacleavoid `pkg-config --cflags playerc++` laserobstacleavoid.cc `pkg-config --libs playerc++` 

If it compiles without any errors then all is good ! .....


SMORGASBORD FOR PLAYER-STAGE

(i) 2.5 Dimension

To see your robot do a 2.5 Dimension, press 'R' (Perspective Camera) while the 2 Dimensional simulation is on !


(ii) Command line check for version

Simple command lines, to confirm the versions of Player and Stage;

(iii) robot-player from ubuntu repositories

In Ubuntu 10.04, one can install robot-player (sudo apt-get install robot-player) from the repositories and the package has been updated for recent versions of Ubuntu, however I faced C++ compilation issues with it.

(iv) Working with a virtual OS

If you are working in a virtual box virtual machine then there may be issues in controlling the robot hardware as hardware layer abstraction is not fully supported. However, simulation in stage is fine.

If you are working on Virtual Box then do Install Guest Additions (This will help to maximise the screen and seamlessly integrate the guest OS with host OS).

(v) 'flickering' in Stage

If Stage starts to flicker too much, then put the 'Visual Effects' in Ubuntu 9.04 to None.


(vi) Recording a video of the simulation


If required, the simulation may be recorded as a video using tools as Record MyDesktop, and then converting the ogg files to to to avi using MEncoder .

(vii) Mailing list and support 



As Player-Stage newbie, one may consider joining the official mailing list and/or the facebook page. 

(viii) Any other success story ? 

This installation also works with Player-3.0.1 and Stage-3.2.0.

I recently tried an overwrite of the player with the latest svn, revision 8767 (3.1.0-svn) and that worked.

However, do not try an overwrite of Stage. 

(ix) Gazebo installation

I have got a few enquiries about Gazebo ! .... and here is my response ! 

I could not install Gazebo, few attempts with version 0.10.0 conflicted with my Stage installation.

I installed ROS in order to work with Gazebo (version 0.9.0). ROS is a another Robotics suite and it uses Stage, Gazebo and a host of other softwares. However the working and command structure are much different from that of Player-Stage.

ROS is a way to use Gazebo without the hassles of bindings etc. A word of advice, ROS recommends Ubuntu 9.10 for installation. So this installation (recommended for Ubuntu 9.04) of Player-Stage may not work in tandem with ROS.

 
In Ubuntu 10.04 LTS, ROS can be installed side by side with Player/Stage without any issues of conflict etc.


For more on ROS and Gazebo - see my article on using gazebo.
 
(x) New drivers

For the adventurous coders, who plans to design new player drivers - have a look at these tutorials,




(xi) New home for the project at github

The project has found a new home at github. Stage 4.0.0 was released on 26 November 2010.


It is worth noting that Stage 4.X.X has back compatibility issues with Stage 3.X.X. Have a look at, Moving from Stage 3 to Stage 4: laser and ranger .

(xii) Installation on Ubuntu 10.04 LTS 

I was able to install Player-3.02 and Stage-3.2.2 on Ubuntu 10.04 LTS, I used the following tutorials;

#. Tutorial 1 - in German

#. Tutorial 2 - more suited to Ubuntu 10.10, but some tips well apply to Ubuntu 10.04

#. Tutorial 3 
 



The major change from installation in 9.04 is the dependencies; rest of the installation is same as that for 9.04.
Dependencies for installation in Ubuntu 10.04;

sudo apt-get install autotools-dev build-essential cmake cpp libboost-python1.40.0 libboost-python1.40-dev libboost-thread-dev libboost-signals1.40.0 libboost-signals1.40-dev libcv4 libcv-dev libgdk-pixbuf2-ruby libhighgui-dev libgnomecanvas2-0 libgnomecanvas2-dev  libgsl0ldbl libgsl0-dev libjpeg62-dev libtool libxmu-dev swig freeglut3 freeglut3-dev libfltk1.1 libfltk1.1-dev libgtk2.0-dev libltdl7 libltdl7-dev libpng12-0 libpng12-dev libcvaux4 libcvaux-dev libltdl-dev libguile-ltdl-1 fluid glutg3-dev freeglut3 freeglut3-dev libart-2.0-2 libatk1.0-0 libboost-thread1.40.0 libboost-thread1.40-dev libc6 libcairo2 libcv4 libcv-dev libcvaux4 libfontconfig1 libfreetype6 libgcc1 libgl1-mesa-glx libglib2.0-0 libglu1-mesa libglu1 libgnomecanvas2-0 libgsl0ldbl libgsl0-dev libgtk2.0-0 libhighgui4 libjpeg62 libjpeg62-dev liblodo0 libltdl7 libpango1.0-0 libplayerc++2 libplayerc2 libplayercore2 libplayerdrivers2 libplayererror2 libplayertcp2 libplayerxdr2 libpmap0 libstdc++6 zlib1g libxmu-dev


(xiii) A vmdk FOR PLAYER/STAGE AND ROS

I have recently made available a vmdk which has Player 3.0.2, Stage 3.2.2 and ROS (Electric) pre-installed.


http://mobotica.blogspot.in/2012/09/a-vmdk-for-ros-electric.html


(xiv) Installation on Ubuntu 12.04

Using Kevin's article I was able to install Player 3.0.2 and Stage 3.2.2 on Ubuntu 12.04 LTS (32 Bit). 


Note for installation in Ubuntu 12.04

Kevin has mentioned that, for installation in Ubuntu 12.04 if Stage compilation gives the following error;

To correct this error you need to make the following changes in CMakeLists.txt where lines

SET (CMAKE_CXX_FLAGS_RELEASE " -O3 -DNDEBUG ${WALL} " CACHE INTERNAL "C Flags for release" FORCE) 
SET (CMAKE_CXX_FLAGS_DEBUG " -ggdb ${WALL} " CACHE INTERNAL "C Flags for debug" FORCE) 
SET (CMAKE_CXX_FLAGS_PROFILE " -O3 -ggdb -pg ${WALL} " CACHE INTERNAL "C Flags for profile" FORCE)

Needs to be changed to,

SET (CMAKE_CXX_FLAGS_RELEASE " -O3 -DNDEBUG -Wl,--no-as-needed" CACHE INTERNAL "C Flags for release" FORCE) 
SET (CMAKE_CXX_FLAGS_DEBUG " -ggdb -Wl,--no-as-needed " CACHE INTERNAL "C Flags for debug" FORCE) 
SET (CMAKE_CXX_FLAGS_PROFILE " -O3 -ggdb -pg -Wl,--no-as-needed " CACHE INTERNAL "C Flags for profile" FORCE)






 
REFERENCES AND INSTALLATION GUIDES FOR OTHER OS

50 comments:

Abe said...

hi arkapravo,
i ve been trying to install P/S on Ubuntu 9.10 since few days ago (glad that someone also tried, and succeed).
i have installation issues, the repo somehow don't have libgdk-pixbuf2, but it has libgdk-pixbuf-ruby.

how to solve that? should i change repo?
anyway, is that library necessary?

thanks,
Abqorian

Arkapravo said...

Hi Abe,

I tired for a long time (23 days) on Ubuntu 9.10, and failed.

I have 2 suggestions for you!

(1)You may install 'robot-player' which has player 2.04 and stage 2.04 from Ubuntu Repositories (sudo apt-get install robot-player) (I had compilation issues , my boost files were conflicting with this installation)

(2)(a) Use Virtual Box and make a VM of Ubuntu 9.04 (The problem here would be, you would be sharing your RAM between 2 OS, thus things may get very slow)

(2)(b) Partition Ubuntu 9.10s drive such that you can find space for about 10-15 Gigs and install Ubuntu 9.04 and rest should be easy ! (This is what I am doing)

I am sorry, I cannot help you with your current issue, I never faced it. Any other issues, then please feel free to write back.

Arkapravo said...

Hi Abe

On second thoughts ! ..... you can try to install the libgdk-pixbuf2 package for Ubuntu 9.04, http://packages.ubuntu.com/jaunty/libgdk-pixbuf2 . However, I do not know if it will work with other bindings of Ubuntu 9.10.

neone said...

Hi Arkapravo,

Thank you very much for the documentation. The steps were very easy to follow and helpful. It saved me a lot of time. I am using a virtual box and Ubuntu 9.04. Gazebo doesn't seem to work on virtual box due to problems of hardware acceleration. Have you tried installing Gazebo on virtual box? Please let me know.

Thanks.

Arkapravo said...

Hi neone,

I was into Virtual Box ! .... however that slowed down things as my RAM was shared by 2 OS (guest and host).

Now, I have partitioned my HDD into Ubuntu 9.10 and Ubuntu 9.04 , Ubuntu 9.04 only for Player-Stage ! .... as of now I have not tried Gazebo ! ... there will be a blog entry as soon I install Gazebo !

One more thing ! ..... you probably cannot control all the hardware aspects with Virtual Box ! .... there is some issue in that , however simulations are cool !

Writer said...

Do you have any ideas or tutorials (or reference websites) for gazebo installation?

Arkapravo said...

Hi

I have not tried to install Gazebo. If I do I will post an article in my blog.

Anonymous said...

hi
I am getting these errors while installing player

make[2]: *** [client_libs/libplayerc++/CMakeFiles/playerc++.dir/playerc++.o] Error 1
make[1]: *** [client_libs/libplayerc++/CMakeFiles/playerc++.dir/all] Error 2

any suggestions?
thanks in advance

Arkapravo said...

Please give more details ! .... if you follow the blog 'exactly' then you should not be getting these issues ! ... which version of player are you using ?

KnudoW said...

THANK YOU!! I've been trying to install this in ubuntu 10.10 for days and I found this, downloaded and installed 9.04 and now player works!!!! Thanks!!!

Maybe you can help me. I have to install a driver, but CMake gives errors in all the player macros...
Unknown CMake command "PLAYERDRIVER_OPTION"
Unknown CMake command "PLAYERDRIVER_REJECT_OS"
... etc

Do you know how to install new drivers?

Arkapravo said...

Hi KnudoW

Nice to know that my blog was some help to you.

Which driver are you trying to install? New drivers are a messy issue, you may have to read through some tutorials for drivers.

Check out these two,

http://image.diku.dk/mediawiki/images/e/e2/Driverhowtodoc_HandedIn.pdf

http://psurobotics.org/wiki/index.php?title=Writing_a_Player_Plugin

usama said...

Hi Arkapravo,

i am using Ubuntu 10.04;
player/stage is successfully installed (when i tpye [which player, which stage]; i get the path /usr/local/bin/player; /usr/local/bin/stage)
now the problem is when i go to playerstage/worlds and type
player simple.cfg
i get the following error
usama@ubuntu:~/playerstage/worlds$ player simple.cfg
player: error while loading shared libraries: libplayerdrivers.so.3.1: cannot open shared object file: No such file or directory

Can u please help me ; how to fix it

The strange thing is that when i type
stage simple.world
it works and a simulation window is opened.

I think that the problem is with the stage..

And obviously ; i would thank u for this excellent tutorials ; keep it up.... :)

waiting for reply

Thnx in advance

regards
usama

Arkapravo said...

Hi Usama

Thanks for your message !

I think that Stage is working fine. However I would guess that there has been some errors when you build your player (.so files are created in that build process - it seems that some did not get created).

Also, it may help to do a double check of all the dependencies (In Ubuntu 10.04 - the dependencies may be different. I cannot really assure you much on Ubuntu 10.04 ... never tried it.)

If all efforts fails then send an email to the forum, there are people working on Ubuntu 10.04 and may be able to help you better.

Regards

Arkapravo

usama said...

Thank u Arkapravo, ! for ur reply;

yes the problem is with the player; i guess ..

i hope i will be able to figure it out soon;

anyways thanks for ur help..
and plz keep uploading the tutorials on player/stage ; u r doing a wonderful job ..

rahul said...

Hi Arkaprova!
i am using Ubuntu 9.04; i tried to install player/stage accoriding to the instructions on ur blog.
i installed all the dependancies of both player and stage and they have been installed correctly, player
has also installed correctly (when i write "which player" in terminal i get the output("/usr/local/bin/player ")
Now the problem is with the stage;
>cd Stage-3.2.0-Source
>cmake .
with this i get the error that "websim" not found[i have searched over the internet and i guess that websim is not necessary for stage but i m nt sure]
>make
it's starts scanning for dependancies; and the scan is correct upto 60%; only some portion of output is shown below[due to limitation of space]:
[ 58%] Building CXX object libstage/CMakeFiles/stage.dir/canvas.o
[ 60%] Building CXX object libstage/CMakeFiles/stage.dir/options_dlg.o
Linking CXX shared library libstage.so
[ 60%] Built target stage
Scanning dependencies of target stagebinary
[ 61%] Building CXX object libstage/CMakeFiles/stagebinary.dir/main.o
Linking CXX executable stage
CMakeFiles/stagebinary.dir/main.o: In function `main':
main.cc:(.text+0x359): undefined reference to `Fl::run()'
libstage.so.3.2.0: undefined reference to `Fl_File_Chooser::value(int)'
libstage.so.3.2.0: undefined reference to `fl_alert(char const*, ...)'
libstage.so.3.2.0: undefined reference to `Fl_Button::value(int)'
libstage.so.3.2.0: undefined reference to `gl_width(char const*)'
libstage.so.3.2.0: undefined reference to `Fl_Gl_Window::flush()'
libstage.so.3.2.0: undefined reference to `Fl_Text_Display::buffer(Fl_Text_Buffer*)'
libstage.so.3.2.0: undefined reference to `Fl_Window::~Fl_Window()'
libstage.so.3.2.0: undefined reference to `Fl_Window::show()'
collect2: ld returned 1 exit status
make[2]: *** [libstage/stage] Error 1
make[1]: *** [libstage/CMakeFiles/stagebinary.dir/all] Error 2
make: *** [all] Error 2
Now how can i fix this; if u can help me please

regards
rahul

Arkapravo said...

Hi Rahul

Can you please confirm if you made the correction in Stage files correctly ?

Stage-3.2.0-Source/libstageplugin/p_driver.cc

closer to the end of the file, Change the line : "world->Update();" to "Fl::wait();"

rahul said...

Hi Arkapravo!

Thanks for the quick reply..

i have tried both with and without changing the line but i am getting the same result... [first i tried by changing the line and then i tried without changing the line but the same error is reported]; i think the issue is not only of changing the line because line can be changed even once stage is installed ; this problem is some what related to linking of libraries;i have even tried reinstalling the player but i didn't succeed even after doing that...

Arkapravo said...

Okay, as of now the best suggestion from my end would be to check the dependencies. Make doubly sure that all of it is indeed there.

I am surprised at the websim thingy - if that continues then join the mailing list at :

https://lists.sourceforge.net/lists/listinfo/playerstage-users

and send a group email. People who have had similar issues may be able to help you out.

Arkapravo said...

Hey Rahul

One more thing - for re-installation of player/stage you may have to remove some of the .so files manually. Otherwise they will conflict with your re-installation.

rahul said...

Hey Arkapravo!!

yes i guess i have to contact player/stage mailing list.

anyways thanks for ur effort....

Kayran said...

Great post!!! With it I could install Stage sucessfully. Thank you so much.

Arkapravo said...

Hi Kayran

You are welcome :-)

Arkapravo

Klovac said...

Hi Arkapravo,
I followed the steps above and was able to successfully install player and stage. However when I finally tried the command: player simple.cfg , I got the error,
error : Failed to load plugin stageplugin.
error : libtool reports error: file not found
error : plugin search path: /home/mishel/Desktop/Stage-3.2.0-Source/worlds:.:/usr/local/lib/
error : failed to load plugin: stageplugin
error : failed to parse config file simple.cfg driver blocks

Do you have any clue how this can be sorted out.
Thanks a bunch.

Arkapravo said...

Hi Klovac

Can you please check the paths, I have explained it in '#.6 Setting the path'.

The 'player' is not able to see 'stage/stage-plugin' - I would guess that it is a path issue.

Regards

Arkapravo

Anonymous said...

Hi Arkapravo,

Great post. Solved my installation problem. Really appreciate what u hv done here.

However i faced a problem when try to run the simple.world / simple.cfg

err: Model type sensor not found in model typetable
err: Unknown model type sensor in world file.

these two errors appeared. Any solution on it?

Thank you.

Arkapravo said...

Hi

Which version of player/stage did you install ? If you are using stage 4.0 and above, then I am afraid I cannot help you.

Do these errors pop up when you try, player simple.cfg ?

These errors usually occur if you have not defined the correct sensor in the cfg file.

Regards

Arkapravo

Anonymous said...

Hi

Thanks for your reply.

I am using Player 3.0.2 and Stage 3.2.2 and my OS is Ubuntu 10.10. The error exists as well when I try player simple.cfg.

Actually I did not manage to install all the libraries listed required by the Player because some of them could not be found anymore. Will this cause the problem occur?

Arkapravo said...

Hmmmmm ...... Well ! .... I know about Ubuntu 9.04 .... Ubuntu 10.10 is not really my strong point.

If you cannot install all the libraries (or suitable alternatives) then I am afraid Player Stage will not function rightly.

Post your issues to the mailing list, Ubuntu 10.10 users may be more help than me.

hiperchelo said...

Hi Arkapravo,

Sorry for my bad english, I want install Stage-3.2.2-Source & Player-3.0.2

Player is ok, but my problem is in Stage,
cmake is ok
make --> showing the following:

marcelo@marcelo-VirtualBox:~/Descargas/Stage-3.2.2-Source/build$ make
[ 1%] Building CXX object libstage/CMakeFiles/stage.dir/region.o
/home/marcelo/Descargas/Stage-3.2.2-Source/libstage/region.cc:10:1: error: la referencia a ‘Region’ es ambigua
/usr/include/X11/Xutil.h:265:26: error: los candidatos son: typedef struct _XRegion* Region
/home/marcelo/Descargas/Stage-3.2.2-Source/libstage/region.hh:61:9: error: class Stg::Region
/home/marcelo/Descargas/Stage-3.2.2-Source/libstage/region.cc:10:1: error: ‘Region’ no nombra a un tipo
/home/marcelo/Descargas/Stage-3.2.2-Source/libstage/region.cc:17:1: error: la referencia a ‘Region’ es ambigua
/usr/include/X11/Xutil.h:265:26: error: los candidatos son: typedef struct _XRegion* Region
/home/marcelo/Descargas/Stage-3.2.2-Source/libstage/region.hh:61:9: error: class Stg::Region
/home/marcelo/Descargas/Stage-3.2.2-Source/libstage/region.cc:17:1: error: ‘Region’ no nombra a un tipo
make[2]: *** [libstage/CMakeFiles/stage.dir/region.o] Error 1
make[1]: *** [libstage/CMakeFiles/stage.dir/all] Error 2
make: *** [all] Error 2
marcelo@marcelo-VirtualBox:~/


What is the problem???? :(
(my system is in the virtual box with Ubuntu 11.10)

Thanks.

Arkapravo Bhaumik said...

Hi hiperchelo

I am not sure if I can be great help - firstly it is in Spanish/Portuguese so I could not get much from the code.

I have not tried Player/Stage in Ubuntu 11.XX, you can check out Jenny's tutorial on installing Player/Stage in Ubuntu 11.04 here,

Jenny's Tutorial

Anonymous said...

Hi Arkapravo,

I was trying to install Player/Stage. The player(3.0.2) was installed successfully however when I tried to compile Stage(4.0.0) these error showed up:
Scanning dependencies of target stageplugin
[ 82%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_driver.o
[ 84%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_actarray.o
[ 86%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_blobfinder.o
[ 87%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_gripper.o
[ 89%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_simulation.o
/home/asus/Stage-4.0.0/libstageplugin/p_simulation.cc: In member function ‘virtual int InterfaceSimulation::ProcessMessage(QueuePointer&, player_msghdr_t*, void*)’:
/home/asus/Stage-4.0.0/libstageplugin/p_simulation.cc:155:52: error: ‘PLAYER_CAPABILITIES_REQ’ was not declared in this scope
/home/asus/Stage-4.0.0/libstageplugin/p_simulation.cc:451:26: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
make[2]: *** [libstageplugin/CMakeFiles/stageplugin.dir/p_simulation.o] Error 1
make[1]: *** [libstageplugin/CMakeFiles/stageplugin.dir/all] Error 2
make: *** [all] Error 2
I downloaded the newest package for Stage on their website.
Do i need to install anything???

Thanks alot,
Kev

Arkapravo Bhaumik said...

Hi

Which Operating System are you using ? Is it Ubuntu ?

Anonymous said...

I'm using ubuntu 11.10

Kev.

Arkapravo Bhaumik said...

I am not sure about Player/Stage in Ubuntu 11.XX, have a look at Jenny's Tutorial on installing Player/Stage in Ubuntu 11.04 -

Jenny's Tutorial

Anonymous said...

I have read it like million times ha ha.
Anyway I really appreciate your concern.
Have a good day.

Kev.

Arkapravo Bhaumik said...

Well ! .... that is all I can help you with, otherwise you can post your issues at the Player/Stage mailing list at playerstage-users@lists.sourceforge.net

Badar said...

well dear i want to know that is this software available for windows?

Arkapravo Bhaumik said...

@Badar I am afraid, I do not have a very positive reply for you - Player is supported in windows not Stage, however ROS is trying to work its way into windows - you can find more on the ROS installation page.

Whatmakessuccess? said...

Hey arkapravo,

I've got a question. How do you compile a code in player? In Jenny Owen's tutorial Chapter 5 she wrote a line " g++ -o example0 ...." to compile a code. So do we create a text file (with extension .cc) copy and paste the long code in Appendix 7.4 and if so where do I place the .cc file. Thanks so much for taking the time to reply to questions since 2 years ago hahah.

Regards
Gughan

Arkapravo Bhaumik said...

@Whatmakessuccess?

hi Gughan,

Jenny's tutorials are available here -
#.1 http://www-users.cs.york.ac.uk/~jowen/player/playerstage-manual.html

and the codes for here -
#.2 http://www-users.cs.york.ac.uk/~jowen/player/tutorial-src.tar

once you extract the folder, you can compile bibbob.cc with the following command,

g++ -o bigbob `pkg-config --cflags playerc++` bigbob.cc `pkg-config --libs playerc++`

Regards,

Arkapravo

Success. said...

Hey Arkapravo,

Sorry but this might seem like a dumb reply but where do you save the bigbob.cc file ? Does it matter where u save it?

Regards
Gughan

Arkapravo Bhaumik said...

@Whatmakessuccess?

hi Gughan,

No, it doesn't matter as to where you save the bigbob.cc file. However, make sure that Player/Stage is installed and paths have been set up in .bashrc (as discussed in my article - http://mobotica.blogspot.in/2010/03/installing-player-stage-what-worked-for.html).

I am more than sure that bigbob works fine for Player 3.0.2 and Stage 3.2.2.

Regards,

Arkapravo

Success. said...

Hey Arkarpravo,

Yup. My player/Stage is working. I can run simulation "simple.cfg" without a problem. However when I run bigbob.cfg the world appears but "bigbob" robot is stationary.

I'll try to find a solution. Thanks once again for your help!

Regards
Gughan
National University of Singapore

Arkapravo Bhaumik said...

@Whatmakessuccess?

hi Gughan,

To make bigbob move, you have to compile bigbob.cc and then run the exe file.

Regards,

Arkapravo

Success. said...

Hey Arkparavo,

I found the solution.

1. Go to the tutorial folder that you mentioned earlier using Terminal and use the long code you gave.
2. Open another Terminal window and head to the Stage/worlds folder and run the .cfg file
3. Go back to the first Terminal and type in ./bigbob
4. It starts running !!!


Even as i'm typing this Bigbob is stuck at some obstacle and not moving for like 5 mins now. Code needs refinement eh.

Arkapravo Bhaumik said...

@Success?

hi Gughan,

You can refine the code by editing it and then compiling it,

g++ -o bigbob `pkg-config --cflags playerc++` bigbob.cc `pkg-config --libs playerc++`

Regards,

Arkapravo

Success. said...

hi arkapravo,

How do I check the code that simple.cfg uses to operate the simulation?

I opened the simple.c file and the code inside does not resemble bigbob.cc at all. I'm looking to refine bigbob's obstacle avoidance.

Thanks in advance!
Gughan

Success. said...

hi arkapravo,

Thanks for replying to my previous comments. Just wondering if you know how to set it such that bigbob1 detects orange blobs only while bigbob2 detects DarkBlue blobs only. Do I have to create a separate .inc for bigbob2?

Regards
Gughan

Supriya Rathi said...

Can someone tell me installing player stage for ubuntu 12.04 64-bit ??

Abhishek Annamraju said...

Hi Everyone,
you can visit the following link to install player/stage,it works for 64-bit 12.04 ubuntu systems

link:http://abhishekannamraju.blogspot.in/